Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce : phpMyAdmin, Cross Site Scripting via db

décembre 2010 par Vigil@nce

Ce bulletin a été rédigé par Vigil@nce : http://vigilance.fr/

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant peut employer le script de recherche de base, afin d’injecter du code JavaScript dans phpMyAdmin.

- Gravité : 2/4
- Date création : 30/11/2010

DESCRIPTION DE LA VULNÉRABILITÉ

Le programme phpMyAdmin permet d’administrer une base de données MySQL.

La fonction PMA_linkOrButton() du fichier libraries/common.lib.php gère les liens. Cependant, cette fonction ne filtre pas les paramètres qu’elle génère.

Le script de recherche de base emploie PMA_linkOrButton() pour générer un lien de confirmation. Ce script peut alors être employé comme vecteur d’attaque.

Un attaquant peut donc employer le script de recherche de base, afin d’injecter du code JavaScript dans phpMyAdmin.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

http://vigilance.fr/vulnerabilite/p...




Voir les articles précédents

    

Voir les articles suivants