Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique





















Freely subscribe to our NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Unsubscribe

Vigil@nce - libyaml: buffer overflow of yaml_parser_scan_tag_uri

February 2014 by Vigil@nce

This bulletin was written by Vigil@nce : http://vigilance.fr/offer

SYNTHESIS OF THE VULNERABILITY

An attacker can generate a buffer overflow of libyaml, in order to trigger a denial of service, and possibly to execute code.

Impacted products: Debian, Fedora, MBS, openSUSE, Puppet, Unix (platform)

Severity: 2/4

Creation date: 12/02/2014

DESCRIPTION OF THE VULNERABILITY

The libyaml library is used to read data files in YAML (YAML Ain’t Markup Language) format.

However, if the size of data is greater than the size of the storage array, an overflow occurs in the yaml_parser_scan_tag_uri() function of the src/scanner.c file.

An attacker can therefore generate a buffer overflow of libyaml, in order to trigger a denial of service, and possibly to execute code.

ACCESS TO THE COMPLETE VIGIL@NCE BULLETIN

http://vigilance.fr/vulnerability/l...




See previous articles

    

See next articles