Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce - PostgreSQL : injection SQL via pg_upgrade/pg_dump

janvier 2019 par Vigil@nce

Ce bulletin a été rédigé par Vigil@nce : https://vigilance.fr/offre

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant peut provoquer une injection SQL via pg_upgrade/pg_dump de PostgreSQL, afin de lire ou modifier des données.

Produits concernés : Unisphere EMC, openSUSE Leap, PostgreSQL, RHEL, SUSE Linux Enterprise Desktop, SLES, Ubuntu.

Gravité : 2/4.

Conséquences : lecture de données, création/modification de données, effacement de données.

Provenance : client internet.

Confiance : confirmé par l’éditeur (5/5).

Date création : 08/11/2018.

Date révision : 09/11/2018.

DESCRIPTION DE LA VULNÉRABILITÉ

Le produit PostgreSQL utilise une base de données.

Cependant, les données provenant de l’utilisateur sont directement insérées dans une requête SQL.

Un attaquant peut donc provoquer une injection SQL via pg_upgrade/pg_dump de PostgreSQL, afin de lire ou modifier des données.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

https://vigilance.fr/vulnerabilite/...




Voir les articles précédents

    

Voir les articles suivants