Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce - Horde : Cross Site Scripting

septembre 2010 par Vigil@nce

Ce bulletin a été rédigé par Vigil@nce : http://vigilance.fr/

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant peut employer un fonctionnalité du Horde Application Framework pour provoquer un Cross Site Scripting dans Horde.

Gravité : 2/4

Date création : 07/09/2010

DESCRIPTION DE LA VULNÉRABILITÉ

Le Horde Application Framework est un framework PHP fournissant des services tels que la compression, la détection du navigateur, la gestion MIME etc.

Cependant, la page util/icon_browser.php du framework vérifie incorrectement les données passées par URL. Le paramètre "subdir" peut alors être utilisé pour exécuter du code HTML dans le contexte du navigateur.

Un attaquant peut donc employer la fonctionnalité icon_browser pour provoquer un Cross Site Scripting dans Horde.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

http://vigilance.fr/vulnerabilite/H...




Voir les articles précédents

    

Voir les articles suivants