Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce - QEMU : use after free via AHCI NCQ

mars 2016 par Vigil@nce

This bulletin was written by Vigil@nce : https://vigilance.fr/offer

SYNTHESIS OF THE VULNERABILITY

An attacker in a guest system can force the usage of a freed memory area with AHCI NCQ on QEMU, in order to trigger a denial of service, and possibly to run code on the host system.

Impacted products : Debian, Fedora, QEMU, RHEL, Ubuntu.

Severity : 2/4.

Creation date : 11/01/2016.

DESCRIPTION OF THE VULNERABILITY

The QEMU product emulates AHCI (Advanced Host Controller Interface).

However, after a AHCI AIO NCQ (Native Command Queuing) command, the ahci_reset_port() function frees a memory area before reusing it.

An attacker in a guest system can therefore force the usage of a freed memory area with AHCI NCQ on QEMU, in order to trigger a denial of service, and possibly to run code on the host system.

ACCESS TO THE COMPLETE VIGIL@NCE BULLETIN

https://vigilance.fr/vulnerability/...




Voir les articles précédents

    

Voir les articles suivants