Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce - OpenSSL : déni de service via OCSP

février 2013 par Vigil@nce

Ce bulletin a été rédigé par Vigil@nce : http://vigilance.fr/offre

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant peut mettre en place un serveur OCSP illicite, afin de stopper les applications OpenSSL qui s’y connectent.

Produits concernés : Debian, OpenSSL, Slackware

Gravité : 2/4

Date création : 05/02/2013

DESCRIPTION DE LA VULNÉRABILITÉ

L’extension OCSP (Online Certificate Status Protocol) vérifie la validité des certificats.

La fonction OCSP_basic_verify() du fichier crypto/ocsp/ocsp_vfy.c décode la réponse OCSP reçue. Cependant, si la clé est vide, un pointeur NULL est déréférencé.

Un attaquant peut donc mettre en place un serveur OCSP illicite, afin de stopper les applications OpenSSL qui s’y connectent.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

http://vigilance.fr/vulnerabilite/O...


Voir les articles précédents

    

Voir les articles suivants