Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Vigil@nce - OpenSSH : injection de commandes xauth

mars 2016 par Vigil@nce

Ce bulletin a été rédigé par Vigil@nce : https://vigilance.fr/offre

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant disposant d’un compte accessible via OpenSSH, mais restreint et sans accès shell, peut transmettre des commandes à xauth via OpenSSH, afin de lire/écrire un fichier avec ses propres privilèges.

Produits concernés : Fedora, FreeBSD, Copssh, OpenBSD, OpenSSH, RHEL, Slackware.

Gravité : 1/4.

Date création : 10/03/2016.

DESCRIPTION DE LA VULNÉRABILITÉ

L’utilitaire xauth gère les accréditations de l’utilisateur pour accéder à X11.

Lorsque X11Forwarding est activé dans sshd_config, le démon OpenSSH transmet les accréditations à xauth. Cependant, OpenSSH ne filtre pas les sauts de lignes contenus dans ces accréditations. Des commandes xauth peuvent ainsi être transmises à xauth. Ces commandes permettent de lire/écrire un fichier avec les privilèges de l’utilisateur, ou de se connecter sur un port.

Un attaquant disposant d’un compte accessible via OpenSSH, mais restreint et sans accès shell, peut donc transmettre des commandes à xauth via OpenSSH, afin de lire/écrire un fichier avec ses propres privilèges.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

https://vigilance.fr/vulnerabilite/...




Voir les articles précédents

    

Voir les articles suivants