Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Avis du CERTA : Vulnérabilités dans MPlayer et xine-lib

février 2008 par CERTA

1 Risque

Exécution de code arbitraire à distance.

2 Systèmes affectés

* MPlayer versions 1.0rc2 et antérieures ;
* Xine-lib versions 1.1.10 et antérieures.

3 Résumé

De multiples vulnérabilités affectant MPlayer permettent à une personne malintentionnée d’exécuter du code arbitraire à distance.

4 Description

De multiples vulnérabilités de type débordement de mémoire ont été identifiées dans MPlayer, dans les fichiers demux_audio.c, demux_mov.c, url.c, et stream_cddb.c. Une personne malintentionnée peut ainsi exécuter du code arbitraire à distance, en incitant par exemple un utilisateur à ouvrir un fichier spécifiquement construit.

La première vulnérabilité se situe en fait dans la bibliothèque xine-lib, et sa fonction open_flac_file() utilisée pour traiter des fichiers de type FLAC. D’autres produits utilisant cette bibliothèque peuvent être affectés.

5 Solution

Se référer aux bulletins de sécurité de l’éditeur pour l’obtention des correctifs (cf. section Documentation).

6 Documentation

* Site de l’éditeur :

http://www.mplayerhq.hu/design7/news.html

* Référence CVE CVE-2008-0485 :

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0485

* Référence CVE CVE-2008-0486 :

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0486




Voir les articles précédents

    

Voir les articles suivants