Rechercher
Contactez-nous Suivez-nous sur Twitter En francais English Language
 

De la Théorie à la pratique











Abonnez-vous gratuitement à notre NEWSLETTER

Newsletter FR

Newsletter EN

Vulnérabilités

Se désabonner

Avis du CERTA : Plusieurs vulnérabilités de Sun Java System Web Proxy Server

décembre 2007 par CERTA

1 Risque

* Exécution de code arbitraire à distance ;
* déni de service à distance ;
* contournement de la politique de sécurité.

2 Systèmes affectés

* Les versions de la branche 3.x de Sun Java System Web Proxy Server antérieures à 3.6 SP11 ;
* les versions de la branche 4.x de Sun Java System Web Proxy Server antérieures à 4.0.6.

3 Résumé

Plusieurs vulnérabilités ont été identifiées dans l’application Sun Java System Web Proxy Server. L’exploitation de ces dernières par une personne malveillante permettrait de contourner la politique de sécurité mise en place.

4 Description

Plusieurs vulnérabilités ont été identifiées dans l’application Sun Java System Web Proxy Server. Les entrées passées en paramètres de certains services de l’application, comme View Error Log ou View URL Database, ne seraient pas correctement vérifiées.

Ces vulnérabilités peuvent être exploitées pour amener l’utilisateur à visualiser dans son navigateur une page malveillante, malgré la politique de sécurité mise en place.

5 Solution

Se référer au bulletin de sécurité de l’éditeur pour l’obtention des correctifs (cf. section Documentation).

6 Documentation

* Alerte de Secunia numéro 28186 du 21 décembre 2007 :

http://secunia.com/advisories/28186/

* Note de mise à jour Sun Java System Web Proxy Server pour la version 3.6 SP11 en novembre 2007 :

http://docs.sun.com/source/820-3637-10/relnotes26sp11_unix.html#wp19247

* Note de mise à jour Sun Java System Web Proxy Server pour la version 4.0.6  :

http://docs.sun.com/app/docs/doc/820-2499/aeaaa?a=view




Voir les articles précédents

    

Voir les articles suivants